OBSERVATIONS IN GUJRAMS CRUD OPERATIONS:
Issue 1: 
Issue: NM → Master Data → Road Details → Add → Fill Details → Save → Unable to save the record and error popup is displaying → Check all components throughout the module → Tested in multiple browsers.
Priority: High
Expected Result: Record should be saved & saved popup should be displayed.
Actual Result: Unable to save the record and error popup is displaying. Attached the screenshot for your reference
Category: Bug
Browser: Firefox
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Issue 2: 
Issue: NM → Master Data → Road Details → Select Record → Delete → Unable to delete the selected record → Check all components throughout the module → Tested in multiple browsers.
Priority: High
Expected Result: Record should be deleted and it should not be in the records page.
Actual Result: Deleted Popup is displaying but the selected one to delete is still displaying in the records. Attached the screenshot for your reference
Category: Bug
Browser: Firefox
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Issue 3: 
Issue: NM → Master Data → Link Details → Add Button → Fill Data → Chainage fields not accepting more than two digits → It is displaying a decimal alert. 
Priority: High
Expected Result: It should accept the whole numbers morethan two digits & Link length should be auto generated basing start and end chainage values.
Actual Result: Chainage fields not accepting more than two digits & it is displaying a decimal alert. & Link length field staying empty after giving a values for start and end chainage.
Category: Bug
Browser: Firefox
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Issue 4: 
Issue: NM → Master Data → Link Details → Add Button → Fill Data → Save → Save button is not clickable. 
Priority: High
Expected Result: Save button should be clickable then successfully saved popup message should be displayed & able to see the saved record in record page.
Actual Result: Unable to click on save button.
Category: Bug
Browser: Firefox
[image: ]
Issue 5: 
Issue: NM → Master Data → Link Details → Add Button → Fill Data → Extra mandatory field added. → Check same for all Crud operations in Link Details Components.
Priority: High
Expected Result: Remove mandatory field for sub division field.
Actual Result: Extra mandatory field added. Please find the screenshot attached for your reference 
Category: Bug
Browser: Firefox
[image: ]
Issue 6: 
Issue: NM → Master Data → Link Details → Select row → Update Button →Update required data → Update → Unable to click on update button. 
Priority: High
Expected Result: Update button should be clickable then successfully Updated popup message should be displayed & able to see the Updated record in record page.
Actual Result: Unable to click on Update button after updating the required fields.
Category: Bug
Browser: Firefox
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Issue 7: 
Issue: NM → Master Data → Link Details → Select row → View Button → For the chainage fields it is displaying decimal related alert. 
Priority: High
Expected Result: It should not display decimal alert → whole numbers and decimals both are acceptable.
Actual Result: For the chainage fields it is displaying decimal related alert.
Category: Bug
Browser: Firefox
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Issue 8: (Done in recent build)
Issue: NM → Master Data → LRP Details → Add Button → Fill Data → Save 
Priority: High
Expected Result:
· Condition should be applied for latitude and longitude i.e; accepts only decimal values. 
· Data Saved Successfully popup should be displayed.
· All the values which user saved should be displayed in the grid.
· Chainage field → Should accept the whole numbers and decimals.
· Remove mandatory field for survey date field.
Actual Result: 
· Longitude and Latitude fields accepting both unlimited alphabets and unlimited numbers.
· Save button is clickable but no popup is displaying.
· Fails to bind the values in the grid after saving the record (Road Code, LRP Type, Chainage).
· In Chainage field more than 2 digits are not acceptable it is displaying decimal related alert.
· Extra Mandatory field is displayed.
Category: Bug
Browser: Firefox
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Issue 9: (Done in recent build)
Issue: NM → Master Data → LRP Details → Select Existing Data → Update Button → Update Data → update 
Priority: High
Expected Result: Mandatory fields should be prefilled & updated values should able to display in the grid.
Actual Result: In Mandatory fields prefilled data not displaying & unable to display the updated data in grid.
Category: Bug
Browser: Firefox


[image: ]
[image: ]
Issue 10: 
Issue: NM → Master Data → LRP Details → Select Row → Delete Button → Delete button is not clickable.
Priority: High
Expected Result: It should display Yes/No options to select if yes deleted popup message should be displayed.
Actual Result: → Delete button is not clickable
Category: Bug
Browser: Firefox
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Issue 11: (Done in recent build)
Issue: NM → Master Data → Video Details → Select Existing Data → Update Button → Update Required Data → update is not clickable.
Priority: High
Expected Result: Able to click on update button then updated successfully popup should be displayed.
Actual Result: After updating required data update is not clickable.
Category: Bug
Browser: Firefox
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Issue 12: (Done in recent build)
Issue: NM → Master Data → GPS Master → Add/Update → Fill/Update Data → Save/Update → Data saved/Updated popup displaying but it displaying no records found.
Priority: High
Expected Result: It should directs to records page and displays records. 
Actual Result: Data saved/updated popup displaying but it displaying no records found.
Category: Bug
Browser: Firefox
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Issue 13: (Done in recent build)
Issue: NM → Master Data → GPS Master → View → Wrong popup message displaying → Check all components in all modules → Tested in multiple browsers.
Priority: High
Expected Result: View related popup message should be displayed.
Actual Result: Update related popup message is displaying for view operation.
Category: Bug
Browser: Firefox
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Issue 14: 
Issue: NM → Master Data → GPS Master → Select Record → Delete → Displaying not related popup message & Displaying No data found → Check all components in all modules 
Priority: High
Expected Result: Displays Deleted Successfully popup message & It should redirects to records page and displays records. 
Actual Result: Selected data deleted and Data popup got displayed & redirecting to records page & displaying no records found.
Category: Bug.
Browser: Firefox
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Issue 15: 
Issue: NM → Master Data → NH Master → Please verify the screenshot attached below. Check all crud operations  
Priority: Normal
Expected Result: 
· Mandatory should be displayed for required field & remove for unwanted field.
· Link length should be auto generated basing start and end chainage values.
· Save,Back & Cancel buttons should clickable and navigated to grid page. Check the same functionality for all the crud operated components.
Actual Result: 
· Missing mandatory Field for Link Length & Not required mandatory field for Is Pilot 
· Link length field staying empty after giving a values for start and end chainage.
· In Add Page Back Navigation, Save & Cancel buttons are not working.
Category: UI Issue & Bug.
Browser: Firefox
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Issue 16: (Done in recent build)
Issue: NM → Master Data → Tehsil Level Chainages → Displaying empty page → Please verify the screenshot attached below
Priority: High
Expected Result: Should display the Tehsil Level Chainages records page 
Actual Result: Displaying empty page.
Category: UI Issue
Browser: Firefox
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Issue 17: 
Issue: NM → Lookup Data → When user try to update records, the heading is displaying as Edit Record.
Priority: High
Expected Result: Heading of update records page should be displayed as update record. 
Actual Result: For same module in the Master Data when user try to update record it is displaying as update record page whereas for lookup data the heading is displaying as edit record.
Category: UI Issue
Browser: Firefox
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Issue 17: 
Issue: RIS → Road Inventory → Crud Operations → Add, update functionality not working → Check all the components for all the screens in RIS module.
Priority: High
Expected Result:
· Should able to Add, Update the record.
· Alignments should be in proper way. 
· User should be able to bind the mandatory field values in the grid.
· Start chainage & End chainage should accept decimal as well as whole numbers.
Actual Result:
· Not able to Add & Update the record.
· Improper Alignments observed.
· Mandatory fields are failing to bind in the grid. 
· Start chainage & end chainage are only accepting two digits or decimals. If user enter more than two digits it is giving decimal alert.
Category: Bug.
Browser: Firefox
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Issue 18: 
Issue: TIS → Survey Data → Traffic Station Details → Select Row to Delete → Click on Delete Button → Click on Delete Confirmation popup YES → Deleted Popup displaying → Still selected record remains in the grid.
Priority: High
Expected Result: Selected record should not remain after deleted successful popup displays.
Actual Result: After deleting popup displaying the record still present in the grid.
Category: Bug.
Browser: Firefox
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Issue 19: 
Issue: TIS → Survey Data → Traffic Volume Count → Add → Add page Displaying as update page.
Priority: High
Expected Result: It should display only Add page when user click on add button.
Actual Result: 
STEPS TO REPRODUCE:
· Step 1: Click on Add Button and fill the fields & save the data.
· Step 2: Record saved & Saved popup Displayed.
· Step 3: Select the record and click on update button.
· Step 4: Update page opened.
· Step 5: Click on cancel button in the update page.
· Step 6: Redirected to Grid page.
· Step 7: Click on Add button then it is directing to update page as shown in the screen shot.
Category: Bug.
Browser: Firefox
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Issue 19: 
Issue: TIS → Survey Data → Traffic Volume Count → Select Row to Delete → Click on Delete Button → Click on Delete Confirmation popup YES → Deleted Popup displaying → Popup Spelling error.
Priority: Normal
Expected Result: Popup message spelling should be like Successfully.
Actual Result: Popup message is displaying as Succefully.
Category: UI Issue.
Browser: Firefox
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Issue 20: 
Issue: TIS → Survey Data → Axle Load → Add → Fill the Fields → Click on Next Button → Next Button is not Clickable, Empty page is displayed in the axle volume count.
Priority: High
Expected Result: 
· Next Button should be clickable then user should able to move the Axle Volume Count section.
· Axle Volume count should be displayed with fields to fill data.
Actual Result: 
· Next button is not performing any action.
· Clicking manually on Axle volume count is displaying as empty with no fields to fill.
Category: Bug.
Browser: Firefox
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Issue 21: 
Issue: TIS → Survey Data → Axle Load → Select Row to Update → Click on Update Button → Displays update page → In Update page in place of cancel button clear button is added.  
Priority: Normal
Expected Result: Cancel button should be added.
Actual Result: In place of cancel button clear button is added.
Category: UI Issue.
Browser: Firefox
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Issue 22: 
Issue: TIS → Survey Data → Axle Load → Delete → Delete Button is not clickable.  
Priority: High
Expected Result: Delete button should be clickable and deleted related popup should be displayed.
Actual Result: Delete button is unclickable.
Category: Bug.
Browser: Firefox
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Issue 23: 
Issue: PMS → Lookup Data → HDM Factors, Speed Flow → Add → Fill Data → Save → Wrong popup message is displaying.  
Priority: High
Expected Result: Data saved successfully popup message should be displayed.
Actual Result: Displaying popup message as Data Data saved Successfully. In this Data is repeating multiple times
Category: Bug.
Browser: Firefox
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Issue 24: 
Issue: PMS → Lookup Data → HDM Factors, Speed Flow, Decision Tree, Work codes → Add → Fill Data → Save → Wrong popup message is displaying.  
Priority: High
Expected Result: Data saved successfully popup message should be displayed.
Actual Result: Displaying popup message as Data Data saved Successfully. In this Data is repeating multiple times
Category: Bug.
Browser: Firefox
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Issue 25: 
Issue: PMS → Lookup Data → Split Merge Ops, Section Criteria → Add → Displaying empty screens.
Priority: High
Expected Result: Should display fields to fill the data and save it..
Actual Result: Displaying empty page with no fields to fill data.
Category: Bug.
Browser: Firefox
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Issue 26: 
Issue: BMS → Missing Mandatory fields
Priority: High
Expected Result: Should Add mandatory field mark(*) for all required fields.
Actual Result: Missing Mandatory fields for all the components.
Category: Bug.
Browser: Firefox

Issue 27: 
Issue: EIS → Survey Data → Air Quality → Select Row → Delete → Yes → Selected record is not deleting and displaying in the grid → Wrong popup message is displaying.
Priority: High
Expected Result: Data deleted successfully popup should be displayed & selected record should be deleted from the grid..
Actual Result: Selected record is not deleting and displaying in the grid → Wrong popup message is displaying.
Category: Bug.
Browser: Firefox
[image: ]
Issue 28: 
Issue: EIS → Survey Data → Tree Count → Add → Start chainage & End chainage should accept decimal as well as whole numbers.
Priority: High
Expected Result: Start chainage & End chainage should accept decimal as well as whole numbers.
Actual Result: Start chainage & End chainage should accept decimal as well as whole numbers.
Category: Bug.
Browser: Firefox
[image: ]



Issue 29: 
Issue: EIS → Survey Data → Noise Level → Add → Fill Details → Save → Displaying wrong popup message & Unable to save data.
Priority: High
Expected Result: Should display Data Saved Successfully popup & data should be saved and located in the grid page .
Actual Result: Displaying wrong popup message & Unable to save data.
Category: Bug.
Browser: Firefox
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Issue 30: 
Issue: RSAMS → Survey Data → Accident Details → Add → Fill Details → Save → Displaying wrong popup message & Unable to save data.
Priority: High
Expected Result: Should display Data Saved Successfully popup & data should be saved and located in the grid page .
Actual Result: Displaying wrong popup message & Unable to save data.
Category: Bug.
Browser: Firefox
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Issue 31: 
Issue: RSAMS → Survey Data → Accident Details → Select Record → Update → Displays Empty Page
Priority: High
Expected Result: For the selected record Pre filled data fields should be displayed to update the required data.  .
Actual Result: Displays Empty page.
Category: Bug.
Browser: Firefox
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Issue 32: 
Issue: RSAMS → Survey Data → Accident Details, iRAP, Blackspots → View → Displaying update related popup message.
Priority: High
Expected Result: Should be displayed Please select a row to view popup message. 
Actual Result: Without selecting when user click on view button it is displaying update related popup message.
Category: Bug.
Browser: Firefox
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Issue 33: 
Issue: RSAMS → Survey Data → Accident Details → Select Record → Delete → YES → Deleted popup displayed but data is still remaining in the grid.
Priority: High
Expected Result: Selected record should be deleted after deleted popup display. 
Actual Result: Deleted popup displayed but data is still remaining in the grid.
Category: Bug.
Browser: Firefox
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Issue 34: 
Issue: RSAMS → Survey Data → Hazardous Location → Add → Start Chainage, End Chainage & Hazardous Location code fields are disabled to fill data → Check all Crud operations.
Priority: High
Expected Result: Able to fill the data . 
Actual Result: Start Chainage, End Chainage & Hazardous Location code fields are disabled to fill data.
Category: Bug.
Browser: Firefox
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Issue 35: 
Issue: RSAMS → Survey Data → iRAP → Select Record → Update → Survey Date is showing as NaN/NaN/NaN.
Priority: High
Expected Result: Should display the exact date which we have given in the add record page. 
Actual Result: Survey Date is showing as NaN/NaN/NaN & When user click on calendar icon in survey date field it is displaying days.
Category: Bug.
Browser: Firefox
[image: ]
Issue 36: 
Issue: RSAMS → Survey Data → Black Spots → Add → Fill Details → Save → Displaying saved popup message and redirecting to grid page.
Priority: High
Expected Result: Should display Data Saved Successfully popup & data should be saved and located in the grid page .
Actual Result: Displaying saved popup message & redirecting to the grid page but we unable see the data there but data is not saving → When we delete data in that particular page then it again directed to grid page there we can see the recently added record..
Category: Bug.
Browser: Firefox

Issue 37: 
Issue: MES → In all components crud operations are not working.
Priority: High
Expected Result: Crud operations should be in workable conditions. 
Actual Result: In this module crud operations are not working properly.
Category: Bug.
[bookmark: _GoBack]Browser: Firefox
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